Users Can't access non-anonymous FTP via Internet Explorer

SafeSquidâ„¢ is a very powerful FTP proxy and can very neatly get you the the contents of FTP services, directories and contents.

Users Can't access non-anonymous FTP via Internet Explorer

Postby edsale » Fri Feb 04, 2011 2:01 am

I have safesquid Plus Edition Version-SR.4.2.2 installed on RHEL 5 and it's not configured as a transparent proxy. Our clients a using IE 7 and 8.
There is no problem accessing anonymous ftp sites like ftp.dell.com or ftp.cisco.com but trying to access ftp sites requesting authentication fails with an "Authorization Failed" error. As you know, IE displays a window asking for a username and password when you request a non-anonymous access to an ftp site but this is not the case using safesquid as a proxy. If we use a direct connection to the site (avoiding the proxy with our network guy's help) we get IE normal behaviour and the authentication window. Using the trick of specifying the username password in the form ftp:\\user:pass@site works just fine, so I believe this is a problem to an ftp request wrapped on http.
Is there a way to configure safesquid so we can have IE normal behaviour when using ftp?

Another thing: the "Authorization Failed" error is not so "clear" the error is a the bottom of the windows and hidden between a lot of code (css and html) see the following:

Code: Select all
<style type="text/css">
.... code and more code.....

.diffremoved { background-color: #ffaaaa; background-repeat: repeat; background-attachment: scroll; font-size: 11px; background-position: 0% 50% }
.diffline { font-weight: bold; font-size: 11px; background-color: #99cccc; background-repeat: repeat; background-attachment: scroll; background-position: 0% 50% }
</style>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head><META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=utf-8">
<base href="http://safesquid.cfg" />
<title>Authorization failed</title></head><BODY><table class="header"><tr><td valign="middle" align="left" width="50%"><img border="0" src="/template/logo" alt="SR.4.2.2.MR.20091205" title="SafeSquid&reg; Content Filtering Internet Proxy " width="195" height="42"  ></td><td valign="top" align="right" width="50%"><B>Plus Edition Version-SR.4.2.2.MR.20091205</B><BR><I>SafeSquid for Licensed Internal Use</I></td></tr></table><br><br><br><table cellspacing="0" cellpadding="0" border="0" width="100%">
<tr><td align="center"><table class="centerdialog" cellspacing="0" cellpadding="0" border="0" width="60%">


Is there a way to get a nice an clean message just as in "squid"? the same ftp problem, was detected using a native squid proxy, but in this case, the message is cleaner.

Thank you

Ed
edsale
 
Posts: 7
Joined: Thu Feb 03, 2011 3:32 am

Re: Users Can't access non-anonymous FTP via Internet Explor

Postby satish7619 » Fri Feb 04, 2011 11:54 am

Hello,

You can upgrade to version safesquid-SR.4.2.2.MR.20101206-plus-standard.tar.gz

The Link is given below

http://downloads.safesquid.net/linux32/ ... ard.tar.gz


and for the authorization ftp server you can use the ftp client having the http proxy settings

or you can type in browser

ftp://username:password@ftpsitename
satish7619
 
Posts: 1146
Joined: Thu Apr 15, 2004 3:55 pm
Location: India

Postby edsale » Fri Feb 04, 2011 9:45 pm

yes, we have been using the workaround of specifying the user:pass in the browser, but due we have a lot of users we wan't to provide a more usual (or default) behaviour.

I'll give a try to the version you recommend and let you know the result.

Thank you sir.
edsale
 
Posts: 7
Joined: Thu Feb 03, 2011 3:32 am

Postby edsale » Sat Feb 05, 2011 4:47 am

ok, I installed the recommend version on a RHEL 4 box and it fails, but I just realized it's due I took a x64 box. We are shutting downt he facility due some problems with the power lines, so I'll back to you next week. Tnx.
edsale
 
Posts: 7
Joined: Thu Feb 03, 2011 3:32 am

Re: Users Can't access non-anonymous FTP via Internet Explor

Postby edsale » Thu Feb 10, 2011 12:01 am

Ok, I installed RHEL 5 32 bits on a pc for testing. This box was patched. I tryed to install safesquid-SR.4.2.2.MR.20101206-plus-standard and it fails. In both cases I'm receiving the following error:
"Validating if ssquid:root can execute /opt/safesquid/bin/safesquid ... Failure!"
also for same reason the safesquid file at /etc/init.d was not created:
"./install.sh: line 397: /etc/init.d/safesquid: No such file or directory" and the service can't be started.

I'll tryied with SELinux enabled and disabled and n both cases I got the same result. I include both installation logs.

Is something wrong with my installation process (I just used the defaults).

Thanks

Eduardo
edsale
 
Posts: 7
Joined: Thu Feb 03, 2011 3:32 am

Postby edsale » Thu Feb 10, 2011 3:29 am

Ok, I tryed a different approach and installed my proviuos working version and then used the new one to patch it and perform the upgrade. After this safesquid started ok. Now, when trying to access internet sites I'm getting the message "Problem with product activation". I believe this is happening due my old version was a trial one. Rigth? Could you give me a link to download a trial of the most recent version?
edsale
 
Posts: 7
Joined: Thu Feb 03, 2011 3:32 am

Re: Users Can't access non-anonymous FTP via Internet Explor

Postby satish7619 » Thu Feb 10, 2011 1:29 pm

Hello,

This is the latest Version

http://downloads.safesquid.net/linux32/ ... ard.tar.gz

and also can you send us your activation key details so that we can verify
satish7619
 
Posts: 1146
Joined: Thu Apr 15, 2004 3:55 pm
Location: India

Postby edsale » Thu Feb 10, 2011 10:28 pm

That's another issue. I don't have an actiation key. We bought Safesquid SMB back in 2006, but seem that the person in charge (he is not longer with us) never get the key (is that or he never took the time to make a proper install). I opened ticket UTSX-856009 with the sales team to get the activation key, I already send a scan of the invoice and I'm waiting for an answer.
edsale
 
Posts: 7
Joined: Thu Feb 03, 2011 3:32 am

Re: Users Can't access non-anonymous FTP via Internet Explor

Postby edsale » Wed Feb 16, 2011 1:43 am

Ok, I got a proposal from sales, and I already downloaded a new trial version for 3 users and now my test machine is Advanced Edition Version-SR.4.2.2.MR.20101206, I got an activation key for this but guess what?, same behavior as reported at first. The behaviour of anonymous ftp is ok, but when need to use a username and password for accessing the ftp site, I got the same giberish as reported at first and the same "autorization failure" error message (see below).

So, my conclusion is that safesquid can not provide a default ftp client behaviour for IE.

Any chance to improve this in the near future?

Regs

Here's part of the giberish displayed:


.diffremoved { background-color: #ffaaaa; background-repeat: repeat; background-attachment: scroll; font-size: 11px; background-position: 0% 50% }
.diffline { font-weight: bold; font-size: 11px; background-color: #99cccc; background-repeat: repeat; background-attachment: scroll; background-position: 0% 50% }
</style>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head><META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=utf-8">
<base href="http://safesquid.cfg" />
<title>Authorization failed</title></head><BODY><table class="header"><tr><td valign="middle" align="left" width="50%"><img border="0" src="/template/logo" alt="SR.4.2.2.MR.20101206" title="SafeSquid&reg; Content Filtering Internet Proxy " width="195" height="42" ></td><td valign="top" align="right" width="50%"><B>Advanced Edition Version-SR.4.2.2.MR.20101206</B><BR><I>SafeSquid for Licensed Internal Use</I></td></tr></table><br><br><br><table cellspacing="0" cellpadding="0" border="0" width="100%">
<tr><td align="center"><table class="centerdialog" cellspacing="0" cellpadding="0" border="0" width="60%">
<tr><td align="center"></td></tr><tr><td align="center"><font size="2">Authorization failed</font></td></tr><tr><td><br></td></tr></table></td></tr></table></body></html>
edsale
 
Posts: 7
Joined: Thu Feb 03, 2011 3:32 am


Return to FTP Proxying

Who is online

Users browsing this forum: No registered users and 1 guest

cron