libgmp.so.3 => not found

Debian is a free operating system (OS) for your computer.

If you have any problem during installtion of safesquid on any version of Debian , you can post your query here.

libgmp.so.3 => not found

Postby JOTER » Sun May 24, 2009 7:26 am

Trying to install the latest Safesquid version on a Debian 5.01 amd64 server system and upon installing an error appears:

"libgmp.so.3 => not found
Please install the necessary dependncies and try again"

Any thoughts?

Regards
joter
JOTER
 
Posts: 4
Joined: Tue Jun 03, 2008 2:11 am

Re: libgmp.so.3 => not found

Postby satish7619 » Mon May 25, 2009 11:36 am

Hello ,

Install this package on your Debian System this will resolve the necessary dependncies and try again.

libgmp3c2
satish7619
 
Posts: 1146
Joined: Thu Apr 15, 2004 3:55 pm
Location: India

Re: libgmp.so.3 => not found

Postby JOTER » Fri May 29, 2009 12:06 am

libgmp3c2 has already been installed.


Regards
joter
JOTER
 
Posts: 4
Joined: Tue Jun 03, 2008 2:11 am

Re: libgmp.so.3 => not found

Postby satish7619 » Fri May 29, 2009 12:11 pm

Hello,

These are the file of the libgmp3c2 .

/usr/lib/libgmp.so.3.4.2
/usr/lib/libgmp.so.3

If you see the output of below command the file libgmp.so.3 is link to file libgmp.so.3.4.2

ll /usr/lib/libgmp.so*

lrwxrwxrwx 1 root root 15 2009-02-03 00:12 /usr/lib/libgmp.so.3 -> libgmp.so.3.4.2
-rw-r--r-- 1 root root 274416 2008-01-24 18:23 /usr/lib/libgmp.so.3.4.2

So i would advice you to just check this file exists or not in your system

libgmp.so.3
satish7619
 
Posts: 1146
Joined: Thu Apr 15, 2004 3:55 pm
Location: India

Re: libgmp.so.3 => not found

Postby JOTER » Sat May 30, 2009 3:30 am

libgmp.so.3.4.2 and libgmp.so.3 exist on my system in /usr/lib/ folder but no luck to continue.

regards
joter
JOTER
 
Posts: 4
Joined: Tue Jun 03, 2008 2:11 am

Re: libgmp.so.3 => not found

Postby Manish » Sat May 30, 2009 12:26 pm

JOTER";p="11868 wrote:Trying to install the latest Safesquid version on a Debian 5.01 amd64 server system and upon installing an error appears:

"libgmp.so.3 => not found
Please install the necessary dependncies and try again"

Any thoughts?

Regards
joter


I think the problem is there because Joter seems to be using 64bit linux.
solutions:
#1 re-install 32bit Debian
#2 carefully install the relevant 32bit compatibility library.
Manish
Site Admin
 
Posts: 1318
Joined: Wed Apr 14, 2004 9:09 pm
Location: Mumbai


Return to Debian Installation Issues

Who is online

Users browsing this forum: No registered users and 1 guest

cron