unable authenticate user access

The external feature allows you to use any program or script to parse the contents of a requested file.

unable authenticate user access

Postby livevid » Tue Sep 27, 2011 7:11 am

Hi support,

we are using windows based pc to setup safesquid

after installing, i create local group, there is no any windows prompt out for name and password before browsing internet.

we can access internet directly. pls guide me

another question :

we do hv domain (domain123.com)

the real domain is with ip: 192.168.1.1, the testing domain which i install for testing is 192.168.1.2, but both domain is same, just different pc and ip

the real domain with username testaccount1, and testaccount2

currently i install safesquid at 192.168.1.2, and i would like to user, after login to 192.168.1.2, before they go internet, it must prompt out the authentication request their username and password.

but i fail to do so, please guide me.
livevid
 
Posts: 12
Joined: Fri Sep 23, 2011 1:23 pm

Postby sachin » Tue Sep 27, 2011 10:59 am

Have you checked out - Configuring Active Directory or LDAP authentication and defining user or group access?

If you have done the above, and still not getting auth challenge, check if you have disabled the default entry in Config > Access Restrictions, that allows access to everyone.
sachin
 

Re: unable authenticate user access

Postby Tech Support One » Tue Sep 27, 2011 11:09 am

Hello,

make sure your ldap configuration is correct or not , through click on "Show ldap group" on safesquid interface ( safesquid.cfg )

if you will be able to get all user & group list in show ldap group means ldap configuration is OK

you can refer this link

http://www.safesquid.com/html/portal.php?page=164

After configuring LDAP ,
if you disable NTLM in Access restriction and enable System authentication in default rule
then authentication prompt will be appear.
Tech Support One
 
Posts: 1458
Joined: Sat Aug 21, 2004 4:43 pm
Location: India

Re: unable authenticate user access

Postby livevid » Tue Sep 27, 2011 2:58 pm

Thanks

But after i set as below:

Option Value
Enabled true
Host Name: domain.com
Ldap IP 192.168.1.1
Ldap Port 389
Use SSL false
Ldap Bind Method NTLM_LDAP_AUTH
Query Record Limit 1024
Ldap Username user1@domain.com
Ldap Password 1c0621181f392407101605
Ldap Basedn DC=domain, DC=com
Login Attribute user1
Group Identifier Memberof

and save and submit, restart safesquid

but when i go to ldap group to show LDAP group, and type in : user1@domain.com or user1, nothing found

or user not found, how?
livevid
 
Posts: 12
Joined: Fri Sep 23, 2011 1:23 pm

Postby sachin » Tue Sep 27, 2011 3:45 pm

'Host name' is not the hostname of the authenticating server, but a proxy server. This is only required in a multi-proxy scenario. Make that field blank.

Change 'Login Attribute' to 'sAMAccountname'.

Make the above changes, save settings and restart SafeSquid service. Then click on 'Show ldap group' and check.
sachin
 

Re: unable authenticate user access

Postby livevid » Wed Sep 28, 2011 5:53 am

Hi,

Thanks a lot, after following you what you mentioned, it work!!! it show ldap group.

however, may i know that, do we need to add in one user by one user inside this ldap configuration?

as i do have about 100 users, impossible i need to add one by one? pls guide
livevid
 
Posts: 12
Joined: Fri Sep 23, 2011 1:23 pm

Re: unable authenticate user access

Postby Tech Support One » Wed Sep 28, 2011 11:11 am

Hello,

You can authenticate your all users through Access restriction

in access restriction

edit default rule and

Enable System Authentication

If this is enabled the all user's authentication response will be processed with LDAP

Or

If you would like to allow access to all the members of a specific OU on the AD, create a rule

Enabled true
Comment This Rule Allow Access For Following Group which is mention in Ldap profile
Profile Tracing true
LDAP Profiles OU=testou1
System Authentication true
Access proxy,http,transparent,connect,bypass
Added profiles Test
Tech Support One
 
Posts: 1458
Joined: Sat Aug 21, 2004 4:43 pm
Location: India


Return to External parser

Who is online

Users browsing this forum: No registered users and 1 guest

cron